php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12273 error while install php4.0.6+apache 2.0.x
Submitted: 2001-07-20 05:42 UTC Modified: 2001-07-26 21:52 UTC
From: cefs99 at yahoo dot com Assigned:
Status: Not a bug Package: *Configuration Issues
PHP Version: 4.0.6 OS: REDHAT 6.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cefs99 at yahoo dot com
New email:
PHP Version: OS:

 

 [2001-07-20 05:42 UTC] cefs99 at yahoo dot com
Modification necessary while install PHP-4.0.6 with Apache 2.0.x

while install PHP as a staic module for Apache 2.0.x ,the INSTALL file with php*tar.gz doesn't mentioned the ncessary change.

1st you must either modify the Configure file or `mkdir /path/to/apache_2.0.a9/src; cp -r /path/to/apache_2.0.a9/include src` since PHP configure script still assume all header files are within the apache_tarball_dir/src but apache_2.0.x don't have the `src` folder at all.

2nd while configure apache to use compiled libphp4.a after install php. should use `--enable-modules=src/modules/php/libphp4.a` instaed of the '-activate-module' option. apache 2.0.x doesn't support it anymore

3rd, seems related to apache, always failed while compileing apache 2.0.x after install php 4.0.6successfuly. the apr stuff seems have some trouble

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-26 21:52 UTC] sniper@php.net
There isn't any configure options to configure PHP as static 
module for Apache2. Also you need the latest versions of 
both Apache2 and PHP (from CVS) to get it work.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 08:01:23 2020 UTC