php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12260 Compile failure --with-oci8 and Oracle 8.0.4
Submitted: 2001-07-19 12:52 UTC Modified: 2002-05-16 00:00 UTC
From: michael at six dot de Assigned:
Status: No Feedback Package: OCI8 related
PHP Version: 4.0.6 OS: Solaris 7 and 8
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: michael at six dot de
New email:
PHP Version: OS:

 

 [2001-07-19 12:52 UTC] michael at six dot de
Compilation failes --with-oci8 and ORACLE_HOME pointing to oracle 8.0.4 installation. A typedef and define for symbol dword is only available in oratypes.h of newer Oracle versions (checked with 8.0.5, 8.1.5 and 8.1.7) .

Solution: change dword to sb4 in ext/oci8/oci8.c, that's still matching the oracle prototype (orl.h of oracle 8.1.7)

sword OCICollAssignElem(    OCIEnv *env, OCIError *err, sb4 index, 
                            CONST dvoid *elem, 
                            CONST dvoid *elemind, OCIColl *coll    );


gcc error:
oci8.c: In function `php_if_ocicollgetelem':
oci8.c:4480: warning: passing arg 7 of `OCIDateToText' from incompatible pointer type
oci8.c: In function `php_if_ocicollassignelem':
oci8.c:4604: `dword' undeclared (first use in this function)
oci8.c:4604: (Each undeclared identifier is reported only once
oci8.c:4604: for each function it appears in.)
oci8.c:4604: parse error before `)'
oci8.c:4626: parse error before `)'
oci8.c:4657: parse error before `)'

cheers,
Michael

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-04-13 08:40 UTC] thies@php.net
please send me a .tar containing the header files for 8.0.4 
 [2002-05-16 00:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2002-05-16 05:42 UTC] michael at six dot de
sent 8.0.4 header files to thies@php.net, but: 8.0.4 is really old now.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sun Oct 24 04:03:35 2021 UTC