php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12223 ldap rebind procedure implementation
Submitted: 2001-07-18 04:21 UTC Modified: 2002-09-20 13:41 UTC
Votes:2
Avg. Score:3.0 ± 2.0
Reproduced:1 of 2 (50.0%)
Same Version:1 (100.0%)
Same OS:1 (100.0%)
From: enrik at planb dot de Assigned: venaas (profile)
Status: Closed Package: LDAP related
PHP Version: 4.0.6 OS: any
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: enrik at planb dot de
New email:
PHP Version: OS:

 

 [2001-07-18 04:21 UTC] enrik at planb dot de
A ldap rebind procedure for automatical referral chase is
not provided in php4. The solution of #9704 doesn't work
for ldap_add et al., as these functions do not return a
"ldap result". This is an inherent problem with synchronous
ldap calls.

I have written an implementation of ldap_set_rebind_proc
registering a php rebind callback. A patch is available on
request (or would it be ok to attach a 240-line patch
here?). The patch is vs. ext/ldap/ldap.c 1.90 from CVS.

Enrik

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-12-29 12:49 UTC] venaas@php.net
There is now an experimental implementation. Please test it.
It currently requires you to use the OpenLDAP HEAD library.
 [2002-05-25 08:58 UTC] derick@php.net
No feedback was provided. The bug is being suspended because
we assume that you are no longer experiencing the problem.
If this is not the case and you are able to provide the
information that was requested earlier, please do so and
change the status of the bug back to "Open". Thank you.


 [2002-09-18 00:44 UTC] cbenedict at synhrgy dot com
Attempted to use this function with php 4.2.2 and OpenLDAP 2.0.23-4 and it did not work.  Apparently, changes to the OpenLDAP API function declaration of ldap_set_rebind_proc were made from 3 parameters to 2 causing the php function to be excluded from the build.  Anyone have info on how to fix?
 [2002-09-20 13:41 UTC] venaas@php.net
You need to use OpenLDAP 2.1.x. The OpenLDAP API had two
parameters and was changed to three in 2.1. It's much
more difficult to implement using the old two parameter
call. I suggest you use the 2.1 API.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Fri Mar 01 15:01:30 2024 UTC