php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #12208 $HTTP_RAW_POST_DATA should always be set
Submitted: 2001-07-17 10:27 UTC Modified: 2001-07-17 14:04 UTC
From: webmaster at brainstatic dot com Assigned:
Status: Closed Package: Feature/Change Request
PHP Version: 4.0.6 OS: NA
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: webmaster at brainstatic dot com
New email:
PHP Version: OS:

 

 [2001-07-17 10:27 UTC] webmaster at brainstatic dot com
$HTTP_RAW_POST_DATA should get set, even if the content type is known. In order to access XML submitted to php (such as with Flash 5 swfs) I need access to $HTTP_RAW_POST_DATA in order to parse it. Instead it gets all munged up in $HTTP_POST_VARS and $HTTP_RAW_POST_DATA is blank.

This bug might be a duplicate of this one: http://www.php.net/bugs.php?id=10520

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-17 14:04 UTC] rasmus@php.net
4.0.7 will have a config directive to turn this on.  If you need it right now, grab the current CVS version of PHP.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon Feb 26 23:01:26 2024 UTC