php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12202 Apache processes keep growing until all memory is used up
Submitted: 2001-07-17 07:40 UTC Modified: 2001-10-21 00:23 UTC
From: alragom at yahoo dot com Assigned:
Status: Closed Package: Apache related
PHP Version: 4.0.5 OS: RedHat Linux 6.1
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: alragom at yahoo dot com
New email:
PHP Version: OS:

 

 [2001-07-17 07:40 UTC] alragom at yahoo dot com
I was attempting to Install Horde & IMP. Following along with their instructions I changed the following settings in the php.ini file : 

magic_quotes_gpc        =       On

To:

magic_quotes_gpc        =       Off

include_path = "" ; UNIX: "/path1:/path2"  

To:

include_path = "/usr/local/lib/php"

Upon restarting Apache ( 1.3.20 installed from sources ) some of it's processes kept growing in memory size up to 100 MB each ! Ofcourse this is where I killed Apache.

THe problem is reproduceable and was fixed simply by changing those settings back to their defaults and starting apache once again.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-21 00:23 UTC] sniper@php.net
Can not reproduce with PHP 4.0.6. 

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Dec 01 20:05:53 2022 UTC