php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12146 PHP warns if mysql have a special problem
Submitted: 2001-07-13 13:36 UTC Modified: 2001-10-23 14:20 UTC
From: alberty at neptunlabs dot de Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.0.6 OS: i686-pc-linux-gnu
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: alberty at neptunlabs dot de
New email:
PHP Version: OS:

 

 [2001-07-13 13:36 UTC] alberty at neptunlabs dot de
Hi,

the follow 'wrong' MySQL statement produce not only a MySQL
error number, it also makes a php warning:

"MySQL: Unable to save result set"

<---snip--->
error_reporting(63);
$query="show table status from foo"; // instead of show table status from foo like 'bar'
$result=mysql_query($query);
if ($result==false) echo "<br>".mysql_errno().": ".mysql_error()."<BR>";
<---snap--->


Regards,

-- 
Steve

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-23 14:20 UTC] sander@php.net
Not a bug. Intended behaviour.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Wed Feb 01 10:03:45 2023 UTC