php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12111 gdImageCreateFromPng dos not work
Submitted: 2001-07-12 13:52 UTC Modified: 2001-08-20 12:10 UTC
From: blon at nfrance dot com Assigned:
Status: Closed Package: GD related
PHP Version: 4.0.6 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: blon at nfrance dot com
New email:
PHP Version: OS:

 

 [2001-07-12 13:52 UTC] blon at nfrance dot com
Hi 

Upgrading from php-4.0.4pl1 to php-4.0.6 gdImageCreateFromPng stops
working. We have this problem on 3 Linux servers but it works fine
open OpenBSD 2.7

On php-4.0.4pl1, configure gives :

checking whether to enable truetype string function in gd... no
checking for libjpeg (needed by gd-1.8+)... yes
checking for libXpm (needed by gd-1.8+)... no
checking for gdImageString16 in -lgd... (cached) yes
checking for gdImagePaletteCopy in -lgd... (cached) yes
checking for gdImageColorClosestHWB in -lgd... (cached) yes
checking for gdImageColorResolve in -lgd... (cached) yes
checking for gdImageCreateFromPng in -lgd... (cached) yes
checking for gdImageCreateFromGif in -lgd... (cached) no
checking for gdImageWBMP in -lgd... (cached) yes
checking for gdImageCreateFromJpeg in -lgd... (cached) yes
checking for gdImageCreateFromXpm in -lgd... (cached) no

All is OK : checking for gdImageCreateFromPng in -lgd... (cached) yes

On php-4.0.61, configure gives :

checking for gdImageString16 in -lgd... yes
checking for gdImagePaletteCopy in -lgd... yes
checking for gdImageCreateFromPng in -lgd... no
checking for gdImageCreateFromGif in -lgd... no
checking for gdImageWBMP in -lgd... yes
checking for gdImageCreateFromJpeg in -lgd... no
checking for gdImageCreateFromXpm in -lgd... yes
checking for gdImageCreateTrueColor in -lgd... no
checking for gdImageSetTile in -lgd... yes
checking for gdImageSetBrush in -lgd... yes
checking for gdImageStringFTEx in -lgd... no
checking for gdImageColorClosestHWB in -lgd... yes
checking for gdImageColorResolve in -lgd... yes
checking for gdImageGifCtx in -lgd... no

Here, the fonction is not found : checking for gdImageCreateFromPng in -lgd... no

All is Ok on an OpenBSD 2.7

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-12 14:05 UTC] rasmus@php.net
What is your ./configure line?
Make sure you specify where your libpng library and header files can be found under.  eg.
--with-png-dir=/usr 
 [2001-07-12 14:20 UTC] blon at nfrance dot com
./configure \
--with-pgsql=/usr/local \
--with-mysql=/usr/local \
--with-imagic \
--with-imap \
--enable-track-vars \
--enable-safe-mode \
--enable-memory-limit \
--enable-magic-quotes \
--enable-roxen-zts \
--with-gd=/usr/ \
--with-png-dir=/usr \
--with-jpeg-dir=/usr \
--with-t1lib \
--with-cpdflib \
--enable-ftp \
--enable-calendar \
--with-gdbm \
--enable-zlib=/usr/ \
--with-zlib-dir=/usr \
--with-gettext \
--with-xml \
--with-dom \
--with-swf \
--with-apache=/usr/local/src/apache_1.3.19

 [2001-07-13 18:21 UTC] blon at nfrance dot com
Hi 

I know that all is OK with GD and PNG so tried
to add

#define HAVE_GD_PNG 1 in main/php_config.h after the configure.

All is OK with that line

The problems seems to come from ./configure
 [2001-07-22 19:07 UTC] joey@php.net
No status was set.
 [2001-07-26 17:33 UTC] sniper@php.net
Check what error is given in config.log file.
Also, try adding --with-zlib to your configure line.

--Jani

 [2001-08-20 12:10 UTC] sniper@php.net
No feedback. Reopen if you still have this problem
with PHP 4.0.7 (soon to be released) or with latest CVS 
snapshot from http://snaps.php.net/

(can't reproduce)

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu Sep 29 02:05:55 2022 UTC