php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12048 Can't have a subdir called PHP in HTDOCS
Submitted: 2001-07-11 09:15 UTC Modified: 2001-07-11 13:54 UTC
From: php at dwatkinson dot co dot uk Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.0.6 OS: Win2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
1 + 18 = ?
Subscribe to this entry?

 
 [2001-07-11 09:15 UTC] php at dwatkinson dot co dot uk
A colleague set up a directory within htdocs called PHP which contained several html & PHP files.

We got a 404 Error every time we wanted to access anything within that directory, and the Apache error log said that the browser was trying to access the file (say test.php) from c:\php\test.php. Turns out it was because the directory was called PHP. I renamed it and all was fine.

I guess it's a mix-up with the ScriptAlias in httpd.conf? Not sure if it's an Apache or a PHP problem, so I thought I'd let you both know!

Didn't find anything on this online anywhere either.

Cheers!


Dave

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-11 13:54 UTC] jeroen@php.net
apache configuration problem.

You have aliased the /php subdirectory, that means that you will not be able to put files in that real directory.

The same for /icons, try having a htdocs/icons/ dir, it won't work with the default installation...

This is not a bug, but a apache-configuration issue. There's no problem when you use the isapi module, but you can also rename the /php script alias to something wierd, like JBSDLJKJVBDS.
 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Jun 22 07:01:29 2024 UTC