php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12044 Duplicate mysql entries, in spite of only one query from php
Submitted: 2001-07-11 07:20 UTC Modified: 2001-10-24 00:57 UTC
From: cbj at improbus dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.0.6 OS: FreeBSD 4.3 / Mandrake 8.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: cbj at improbus dot com
New email:
PHP Version: OS:

 

 [2001-07-11 07:20 UTC] cbj at improbus dot com
Hi!

I have a strange problem, that I think has to be a bug:

1. My PHP script does a MySQL query, like this:

  $dbname = "testcounter";
  $dbhost = "localhost";
  $dbuser = "root";
  $dbpass = "somepass";

  $dbconn = mysql_connect($dbhost, $dbuname, $dbpass);

  $q  = "INSERT INTO counter (visitorhost) VALUES ('someinfo');";
  $qq = mysql_db_query($database, $q);

2. When I perform a manual sql query;

SELECT counter, visitorhost FROM counter;

... I get not only one entry, but TWO for each time the script is loaded.

Here are the original files:

http://beta.robodoc.net/test/index.txt - the PHP(s) file
http://beta.robodoc.net/test/testcounter.txt - a mysqldumped TAB file

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-10-23 14:19 UTC] sander@php.net
Can you post your configure-line?
 [2001-10-24 00:57 UTC] sniper@php.net
Not a bug, see this bug report for more information:

http://bugs.php.net/bug.php?id=10599

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Jan 28 19:03:44 2023 UTC