php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12029 "--with-apxs" can cause the error "MySQL: Unable to save result set in"
Submitted: 2001-07-10 21:41 UTC Modified: 2002-01-23 10:48 UTC
Votes:2
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: root at byone dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.0.6 and 4.1.0RC3 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
10 + 4 = ?
Subscribe to this entry?

 
 [2001-07-10 21:41 UTC] root at byone dot com
I had read #12009 and #11765
I found that the same error may be generated by the configuration tag "--with-apxs" 
I recompiled php-4.0.6 just without "--with-apxs" and then ran the same script error.php(src posted in #12009) through the command line ---

root@localhost # php ./error.php
X-Powered-By: PHP/4.0.6
Content-type: text/html

root@localhost #


NO ERROR at all!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-01-23 10:48 UTC] mrobinso@php.net
Apache is installed with mod_log_mysql and mod_auth-mysql,
and php is installed with the built-in clients.

http://www.php.net/manual/en/faq.databases.php#AEN73271

Please reopen with a url to a phpinfo() call if problem
persists.
 [2003-10-03 05:19 UTC] sietzepost at streetwisedd dot nl
Please read Bug #16906, wich is a follow up. The problem is not PHP-related, but a MySQL table/key corruption. Running myisamchk should resolve it.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Oct 03 03:05:54 2022 UTC