|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #12010 Unable to save result set in
Submitted: 2001-07-10 09:35 UTC Modified: 2001-10-24 00:59 UTC
From: kuba at 3net dot pl Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.0.6 OS: Linux new 2.2.16-storm #1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: kuba at 3net dot pl
New email:
PHP Version: OS:


 [2001-07-10 09:35 UTC] kuba at 3net dot pl
mysql_query("INSERT INTO intranet (login,imie_nazwisko,haslo) VALUES ('milewskij','','657998')");

 './configure' '--prefix=/usr' '--with-apxs=/usr/bin/apxs' '--with-regex=system' '--with-config-file-path=/etc/php4/apache' '--enable-calendar' '--without-dom' '--enable-filepro' '--enable-ftp' '--enable-sysvsem--enable-sysvshm' '--enable-track-vars' '--enable-trans-sid' '--disable-static' '--with-gd' '--with-mm' '--with-mysql=/usr/local/mysql' '--with-pcre-regex=/usr' '--enable-sockets' '--with-ttf' '--with-yp' '--with-zlib' '--with-jpeg-dir=/usr' '--with-png-dir=/usr'

mysql_query only returns error with INSERT and DELETE (no problem with SELECT)

I tried to recompiled with path to mysql, as you've said in FAQ, but it didn't solve problem...

the same script with the same mySQL databases running on PHP 4.0.2, the same mySQL (the 3.23.39), on Redhat 7 returns no error

please help me ASAP

script with error:


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-10 09:37 UTC]
Submitted twice
 [2001-07-11 07:31 UTC] kuba at 3net dot pl
sorry - submitted twice cause my browser's window closed when I tried submit first time

As I said  recompiled php with 
and still got error "Unable to save result set in..."

according to bug report #11015
I've checked settings in php.ini, but
is correct

however, mod_auth_mysql that I'm using required other socket, so I made link from mod_auth's socket localization
to /tmp/mysql.sock (then mod_auth started working correctly)

PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Feb 04 06:05:49 2023 UTC