php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #11987 General scripting features/build
Submitted: 2001-07-09 16:00 UTC Modified: 2002-02-09 23:40 UTC
From: dphillips at vsni dot com Assigned:
Status: Duplicate Package: Feature/Change Request
PHP Version: 4.0.6 OS: any
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: dphillips at vsni dot com
New email:
PHP Version: OS:

 

 [2001-07-09 16:00 UTC] dphillips at vsni dot com
It would be very nice to have a non-CGI version of PHP for using as a stand-alone command line interpreter.  Perhaps a separate build option for this could be added, such as "--with-standalone", although this could be done entirely through configuration options.  However, not being dependent on a configuration file at all would be beneficial.

- Not require the "-q" quiet option to disable outputting CGI headers.

- Not require start/end tags.  It is usually not useful in a scripting language to pass text directly through to the output stream.

- Have the standard file handles already open and available, in the same manner as $argc and $argv: $stdin, $stdout and $stderr.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-02-09 23:40 UTC] jimw@php.net
duplicate of #11944.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sun Dec 08 15:01:25 2019 UTC