php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11920 e.g. mysql_unbuffered_query doesn't function but throws no error to indicate
Submitted: 2001-07-06 04:20 UTC Modified: 2001-11-20 19:30 UTC
From: gwelters at weos dot de Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.0.5 OS: linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gwelters at weos dot de
New email:
PHP Version: OS:

 

 [2001-07-06 04:20 UTC] gwelters at weos dot de
It's a BIG BIG Problem to find the reason why your application doesn't work when there's NO indication that a implemented php-function does NOT what it should do, without trowing any error!

Thats what happened as I tried to move back from 4.0.6 to 4.0.5 due to a BIG bug in the memory-management of 4.0.6:

for 4.0.6 I replaced mysql_query with mysql_unbuffered_query in one function. There was no Prob with that in 4.0.6...but after I had 4.0.5 back again my app didn't work anymore without giving any indication of the reason.

It would be great if the php-developers could provide a bit more error-messages for instance when mysql_unbuffered_query works only for SELECT's, not for INSERT's, why not throw a WARNING or ERROR if you try to use the wrong query.

this would avoid Days of debugging!



Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-20 19:30 UTC] mfischer@php.net
Thanks for the info. But we won't release a bugfixed version of 4.0.5. Developers try hard but sometimes everyone makes a mistake.

Btw, if you still have memory management problems with 4.0.6 give it a try with latest RC

http://www.php.net/~zeev/php-4.1.0RC3.tar.gz

Not really a bug anymore, bogus.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sat Feb 04 15:04:09 2023 UTC