php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11913 include() before sending headers causes hang
Submitted: 2001-07-05 14:19 UTC Modified: 2002-06-02 14:01 UTC
From: junk dot nathan at home dot com Assigned:
Status: Not a bug Package: PWS related
PHP Version: 4.0.6 OS: Windows 98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: junk dot nathan at home dot com
New email:
PHP Version: OS:

 

 [2001-07-05 14:19 UTC] junk dot nathan at home dot com
[contents of testinclude.php]
<?php include("myinclude.php"); ?>
some text

[contents of myinclude.php]
some included text


This causes MS Personal Web Server on Win98 to hang (using php.exe, not the isapi dll).  It works fine on Apache.  If I change testinclude.php to include a space or newline or anything before the "<?php", it works fine on PWS.  Contents of the included file don't seem to matter.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-06-02 14:01 UTC] derick@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Aug 17 14:05:44 2022 UTC