php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11876 gmdate() and date() wont generate a date greater than January 19, 2039
Submitted: 2001-07-04 08:38 UTC Modified: 2001-07-04 12:43 UTC
From: ryan at jarp dot cjb dot net Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 4.0.6 OS: Windows ME
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ryan at jarp dot cjb dot net
New email:
PHP Version: OS:

 

 [2001-07-04 08:38 UTC] ryan at jarp dot cjb dot net
gmdate() and date() wont generate a date greater than January 19, 2039 @ 3:14:07 AM. if you write gmdate("F j, Y @ g:i A", 2147483647) it gives you "January 19, 2039 @ 3:14:07 AM", but if you add one second to it and do gmdate("F j, Y @ g:i A", 2147483648) it gives you an error.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-04 08:40 UTC] derick@php.net
This is not a bug in PHP, but a limitated in your OS.
The time field is only 32 bits which means that dates larger then the date you want does not work.

Derick
 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC