php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11868 Improper character encoding
Submitted: 2001-07-04 05:13 UTC Modified: 2001-11-15 08:21 UTC
From: john at lerach dot cz Assigned:
Status: Closed Package: MSSQL related
PHP Version: 4.0.6 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: john at lerach dot cz
New email:
PHP Version: OS:

 

 [2001-07-04 05:13 UTC] john at lerach dot cz
I am using PHP, Apache 1.3 and MSSQL 2000 server via mssql_* functions. If I SELECT some text types with czech characters (ie š ž etc.) these characters are malformed. If I INSERT and SELECT these chars directly from browser, they seem to be OK in browser, but not in direct DB view, so I suppose it is caused by incompatible character encoding between Apache, PHP and MSSQL server.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-14 18:04 UTC] fmk@php.net
In the "MS SQL Server Client Network Utility" tool under "DB-Library Option" you can specify Automatic ANSI to OEM convertion.
Change this setting and your problem should be solved.
 [2001-11-15 08:21 UTC] john at lerach dot cz
Closed, thanx alot!!!
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri May 27 18:06:15 2022 UTC