php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11818 Using the PDF functions after July 1st triggers an internal PDFlib error
Submitted: 2001-07-01 03:53 UTC Modified: 2001-07-01 06:54 UTC
From: jpm at phpbrasil dot com Assigned:
Status: Closed Package: PDF related
PHP Version: 4.0.5 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jpm at phpbrasil dot com
New email:
PHP Version: OS:

 

 [2001-07-01 03:53 UTC] jpm at phpbrasil dot com
Ok, I know this sounds unbelievable but its exactly what is happening here. I'm running a script that calls this class which creates a PDF document on the fly, and everything was working perfectly.

Working late at night surprised me when an error that I never saw before appeared on my browser:

Fatal error: PDFlib error: Beta expired - retrieve new version from www.pdflib.com in c:\www\htdocs\boleto.pessoal.org\docs\include\boletos\class.pdf.php on line 52

I changed my internal Windows clock to May 1st and the script started working again. Is this a known problem ? It seems kinda ridiculous to have a time limit to use a PHP extension.

That line 52 is the line that contains '$pdf = pdf_new();'. I'm not sure if this happens on every operating system, but it is still a serious problem.

Joao Prado Maia

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-07-01 06:54 UTC] derick@php.net
This is not a bug in PHP, but some thing in the PDF library it self. Complain to the pdflib.com guys about this.

Derick
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Dec 03 09:01:24 2020 UTC