php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11782 Select from Array
Submitted: 2001-06-28 11:34 UTC Modified: 2001-06-30 05:03 UTC
From: aubrey at isoft dot co dot za Assigned:
Status: Not a bug Package: ODBC related
PHP Version: 4.0.6 OS: Linux RedHat 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: aubrey at isoft dot co dot za
New email:
PHP Version: OS:

 

 [2001-06-28 11:34 UTC] aubrey at isoft dot co dot za
When I run an odbc_exec from PHP-4.0.2 which connects to a Progress 83C database in order
to retreive an array field as follows:

select name,narrative@1 from customer

I get an SQL syntax error as follows:

Warning SQL Error [OpenLink][ODBC] Syntax error or access, SQL State 37000 in
SQLExecDIRECT

It works on NT.


It would seem that PHP don't like the @ sign, How can I get it to like it.

TIA

Aubrey

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-30 05:03 UTC] hholzgra@php.net
this looks like an ODBC driver incompatibility
between the NT version and the Openlink driver,
it is most likely not related to PHP at all,
as PHP does only pass it on from ODBC to its
error log

you should report this error to the OpenLink 
maintainers instead IMHO
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Dec 02 10:01:24 2020 UTC