php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11698 Memory leak
Submitted: 2001-06-26 10:09 UTC Modified: 2001-12-03 00:08 UTC
From: stefan at digiconcept dot net Assigned:
Status: Closed Package: DOM XML related
PHP Version: 4.0.6 OS: Win NT 4.0 SP 6
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: stefan at digiconcept dot net
New email:
PHP Version: OS:

 

 [2001-06-26 10:09 UTC] stefan at digiconcept dot net
Hi!

I'cant more focus on the real problem, but the compiled Windows-Version of PHP6, running as an apache module, leaks memory ! Somtimes there are several hundreds of kilobytes (!!) remaining as carbage.

I've include additionally the following .dll's: gd,domxml,zlib

greetings in advance
Stefan

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-26 22:49 UTC] cmv@php.net
Undoubtedly this is the domxml extension.  The *nix side leaks memory pretty badly as well, IIRC.
 [2001-06-27 08:41 UTC] sniper@php.net
I'd like to know how you can tell that there is a leak
on windows? 

--Jani

 [2001-06-27 08:42 UTC] sniper@php.net
And if you disable domxml extension, does it continue to leak?

 [2001-06-27 10:06 UTC] stefan at digiconcept dot net
The memory usage of my webserver (apache 1.3.19) is growing .. and growing ... and growing ... until m< mashine craches.

disabling the domxml-functions? sorry, I depend on them.
But I disable them, the growing is slower but still there ...
Stefan
 [2001-06-27 13:33 UTC] sniper@php.net
Does this happen with certain script?
If so, please include short version of the script
that still reproduces the leak.

 [2001-06-28 09:55 UTC] sniper@php.net
Most of the leaks are caused by domxml-functions.


 [2001-12-03 00:08 UTC] mfischer@php.net
Memory leaks should be gone by now (in CVS).

If you still find any, re-open and give short, self-containing sample script.

Closing.
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Thu Feb 20 05:01:27 2020 UTC