php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11686 if configuring with db2 AND java-support, java will hang under apache
Submitted: 2001-06-26 02:26 UTC Modified: 2001-07-25 12:16 UTC
From: mtmmtm at usa dot net Assigned:
Status: Closed Package: Java related
PHP Version: 4.0.6 OS: linux redhat 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mtmmtm at usa dot net
New email:
PHP Version: OS:

 

 [2001-06-26 02:26 UTC] mtmmtm at usa dot net
build php with db2-support, AND java, and ONLY when running it under APACHE (I tried several versions, but last time i used:1.3.20).

If i remove db2-support, it works ok, or run php standalone.

this bug exists in db2 7.1 (patchlevel 0,2,3 (latest)).

i have reproduced it under ibmjdk118, ibmjdk1.3, suns jdk1.2.2, suns jdk1.3.

workaround:  don't use db2 in php, do it from java instead.

cd /root
tar xvfz apache_1.3.20.tar.Z 
cd apache_1.3.20
./configure --prefix=/usr/local/apache --enable-module=so
make
make install

# 1.3
tcsh
setenv LD_ASSUME_KERNEL 2.2.5
setenv LD_LIBRARY_PATH /opt/jdk1.3/jre/lib/i386/client:/opt/jdk1.3/jre/lib/i386/classic:/opt/jdk1.3/jre/lib/i386
set path = ( /opt/jdk1.3/bin/ $path )
./configure --with-apxs=/usr/local/apache/bin/apxs --without-mysql --enable-sockets --with-java 
make
make install

restart apache)
(try run except.php to load java from apache).
now it works...

then:

add this line to php, (and make rm -rf on the php-directory, because of severe bugs in the configure/make process) (only configure from scratch work 100%).
--with-ibm-db2=/home/db2inst1/sqllib 
(also add /usr/Ibmdb2/V7.1/lib to LD_LIBRARY_PATH)

(restart apache)
(try run except.php (from netscape) to load java from apache).
now it does not work.
there will be NO response output.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-26 08:45 UTC] sniper@php.net
I hope you're not using 'apachectl restart'? Use stop/start instead. If this wasn't the problem, please generate
a GDB backtrace of the crash. Instructions can be found here:

http://www.php.net/bugs-generating-backtrace.php


 [2001-06-26 08:45 UTC] sniper@php.net
One more thing, does db2 work if you leave java out?

 [2001-06-27 11:50 UTC] sniper@php.net
Please read the email to the end..and you will find
the URL which to use to reply. DO NOT REPLY VIA EMAIL!!!

 [2001-06-27 11:51 UTC] sniper@php.net
Please include the shortest possible script into this report
which can be used to reproduce this.

 [2001-07-25 12:16 UTC] kalowsky@php.net
no user feedback.  if this problem still persists, please reopen the bug.
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Nov 30 02:03:13 2021 UTC