|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11659 fsockopen and fopen
Submitted: 2001-06-25 09:02 UTC Modified: 2001-06-27 13:31 UTC
From: the_polymorph at rocketmail dot com Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4.0.6 OS: Red Hat Linux 6.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
Solve the problem:
47 - 4 = ?
Subscribe to this entry?

 [2001-06-25 09:02 UTC] the_polymorph at rocketmail dot com

 $fd = fopen("", "r" );




I am also unable to write *functional* scripts using fsockopen...

My compile line was:

#./configure --with-mysql=/usr/local/mysql-3.22.32-pc-linux-gnu-i686/

make install

I am using Netscape 4.51.

Thanks, Katie.


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-26 05:42 UTC]
Your example script works just fine. 
Can you please explain what exactly doesn't work?
And preferrably include suck non-working example
script (short one) into this bug report.

 [2001-06-26 11:26 UTC] the_polymorph at rocketmail dot com

 It seems I made an error in not securing my machine from the clutches of my roommate. He started 20 seperate httpd processes! When I went through and used kill -9 on all of them and re-started the web server, the php code worked.
Sorry. I did receive the error style/css on found on the server. What does this mean and how can I fix it?

 I am a serious PHP user and your assistance is very much appreciated. Are there any areas I should look for onm own so I won't take up too much of your time? Such as php.ini in case I have another question?

Thanks, Katie.

 [2001-06-26 11:28 UTC] the_polymorph at rocketmail dot com

 The error I *was* receiving was the same as Bug i.d. #11058


 [2001-06-26 12:10 UTC] the_polymorph at rocketmail dot com

 New problem / question.

 The following code generates the following error:

 Not Found

 The requested URL/style.css was not found on this server.



  $webpage = "";

  $fp = fopen( $webpage, "r" ) or die("Couldn't open    $webpage");

while( ! feof($fp ))
 print fgets( $fp, 1024 );



I tried it again with the URL:
and it wouldn't connect. The output was consistently:

"couldn't open"



 [2001-06-27 09:45 UTC]
Is the .html suffix regocnized to be run by PHP ?
I get 'file not found' on that url too. Or did you
delete it already? 

And your script works for me just fine.


 [2001-06-27 11:10 UTC] the_polymorph at rocketmail dot com

 I checked that url ( ) and they evidently deleted the hello.html file. My httpd.conf file is set up to recognize these file types:


an error about style/css not found on this server when I attept to open the site. Is this an include?

 Thanks, Katie.

 [2001-06-27 13:31 UTC]
Obviously you really don't know PHP too well.
Please ask further support questions elsewhere,
e.g. at 

PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 22:05:44 2022 UTC