php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11637 GD compilation failure with GD1.5
Submitted: 2001-06-24 02:07 UTC Modified: 2001-06-24 08:50 UTC
From: mkong at intisoft dot com Assigned:
Status: Not a bug Package: GD related
PHP Version: 4.0.6 OS: Linux 6.1 x86
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: mkong at intisoft dot com
New email:
PHP Version: OS:

 

 [2001-06-24 02:07 UTC] mkong at intisoft dot com
This is related to bug 10593.  4.0.6 still failes to compile with GD 1.5.  gdImageGifCtx is indeed in the GD lib, that's why HAVE_GD_GIF_CTX is set.  But gdImageGifCtx prototype is not available in GD header files, so the compilation fails.  I have changed line 1401 to #ifdef HAVE_GD_GIF_CTX_NEVER_WILL_HAPPEN just to get the compilation going.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-24 08:50 UTC] sniper@php.net
You must have some other libgd.a|so which is used
since in my libgd-1.5 there is no gdImageGifCtx() function
in it.

--Jani

 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC