|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #116 Apache Module Installation Problem
Submitted: 1998-02-28 04:02 UTC Modified: 1998-02-28 17:06 UTC
From: ctammel at mindspring dot com Assigned:
Status: Closed Package: Installation problem
PHP Version: 3.0b5 OS: Solaris 2.5.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: ctammel at mindspring dot com
New email:
PHP Version: OS:


 [1998-02-28 04:02 UTC] ctammel at mindspring dot com
In trying to install PHP3b5 with Apache 1.2.5 or 1.3b5
it appears that although the appropriate line is being
added to the Configuration file configure never compiles 
the mod_php3.c file or try to include it.

Module php3_module mod_php3.o      (for Apache 1.2.5)
AddModule modules/extra/mod_php3.o (for Apache 1.3b5)

I've tried hand editing the Makefile for Apache 1.2.5 and
it then compiles the mod_php3.c file and creates a
2+ mbyte httpd file (only mod_rewrite is added) when
previously it was .4 mbytes.  However, when I run the
httpd file .php3 files come up with a set the application
error in the browser because the srm.conf file is pointing
it to an application it doesn't know what to do with.

AddType application/x-httpd-php3 .php3

I've tried doing it with csh or just sh.  I currently
have Apache 1.2.1 running with PHP2.0b12 and it works great.


Craig Tammel


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [1998-02-28 17:06 UTC] zeev
Missing trailing newlines in the Configuration file
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Sat Apr 20 18:01:29 2024 UTC