php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Doc Bug #11598 Distinguish between php.ini and httpd.conf levels (PHP_INI_SYSTEM)
Submitted: 2001-06-20 22:36 UTC Modified: 2003-07-15 01:44 UTC
Votes:1
Avg. Score:5.0 ± 0.0
Reproduced:1 of 1 (100.0%)
Same Version:0 (0.0%)
Same OS:0 (0.0%)
From: danbeck@php.net Assigned:
Status: Closed Package: Documentation problem
PHP Version: 4.3.0 OS: All
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: danbeck@php.net
New email:
PHP Version: OS:

 

 [2001-06-20 22:36 UTC] danbeck@php.net
The "Configuration" section of the documentaion does not distinguish between configuration settings that are admin level, user level or any level.  Each configuration option should indicate what restrictions are placed on it as to where and how can be set in the Apache conf.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2002-08-17 01:42 UTC] kalowsky@php.net
Can you give an example of the text you would like to see?
 [2002-08-17 06:21 UTC] goba@php.net
IMHO all conf options should have the info available for general options at ini_set()...
 [2002-09-18 01:00 UTC] php-bugs at lists dot php dot net
No feedback was provided for this bug for over a month, so it is
being suspended automatically. If you are able to provide the
information that was originally requested, please do so and change
the status of the bug back to "Open".
 [2003-01-31 13:34 UTC] philip@php.net
This is documented at ini_set() as well as config.xml in the 'changes' section.  We are looking into moving the table found in ini_set() to it's own location closer to config.xml as it's not specific to ini_set().  But the information does exist now so the original bug is closed.

This bug is being changed as a request to document which directives can be set in php.ini but not httpd.conf as disable_functions is one of them and there are more.  Currently the docs do not distinguish the differences of PHP_INI_SYSTEM
 [2003-07-15 01:44 UTC] philip@php.net
Since there are only two directives that differ from the standard PHP_INI_SYSTEM definition, there is not much that needs to be done here.  This information is documented for each, this bug is closed.  (btw, disable_classes is the other).

http://us2.php.net/manual/en/features.safe-mode.php
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Mon Sep 27 00:03:38 2021 UTC