php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11548 sub select??
Submitted: 2001-06-18 23:58 UTC Modified: 2001-06-19 07:25 UTC
From: akhil_chugh at yahoo dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: Earlier? Upgrade first! OS: red hat 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: akhil_chugh at yahoo dot com
New email:
PHP Version: OS:

 

 [2001-06-18 23:58 UTC] akhil_chugh at yahoo dot com
dear sir
 i want to know if the followign scenario has some work around possible
 i have a table to project_users and a table of users.
 when some one joins my organization i add him in the user table adn then when he becomes a part of a project he is added to the project users table
 to add him to a project he should not already be a part of that project
 so i want to execute a query of the form
  select user_id from users where user_id NOT IN ( select user_id from project_users where project_id = $selected_project)
 but as you know mysql doesn't support sub-select .]
 so is there a workatround using php to handle this sub select pls reply soon
 thanx
--akhil 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-19 07:08 UTC] swm@php.net
This is not a users forum. Please address such queries to
SQL/MySQL/php user lists or forums.

Also, please read http://www.php.net/bugs-dos-and-donts.php
before posting.
 [2001-06-19 07:25 UTC] derick@php.net
Not a bug. This is a known limitation of MySQL.
 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Feb 05 16:05:48 2023 UTC