php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11539 Oracle_Apache / PHP Installing
Submitted: 2001-06-18 10:03 UTC Modified: 2002-04-13 08:38 UTC
From: jana dot korpasova at unex dot cz Assigned:
Status: Closed Package: OCI8 related
PHP Version: 4.0.6RC3 OS: AIX 4.3.3
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: jana dot korpasova at unex dot cz
New email:
PHP Version: OS:

 

 [2001-06-18 10:03 UTC] jana dot korpasova at unex dot cz
Hello !
I'm trying to install PHP 4.04pl1 as Apache module with  Apache 1.3.12 installed with Oracle iAS 1.0.2.1

PHP compiled fine with such options:
/configure --with-apxs=../Apache/Apache/bin/apxs
but make install gets errors:

Making install in Zend
Target "install-exec-am" is up to date.
Target "install-data-am" is up to date.
Target "install" is up to date.
Making install in main
Target "install-p" is up to date.
Target "install" is up to date.
Making install in ext
Making install in mysql
Making install in libmysql
        /bin/sh /php-4.0.4pl1/libtool --silent --mode=compile gcc  -I. -I/php-4.0.4pl1/ext/mysql/libmysql -I/php-4.0.4pl1/main -I/php-4.0.4pl1 -I/include -I/php-4.0.4pl1/Zend -I/php-4.0.4pl1/ext/mysql/libmysql -I/php-4.0.4pl1/ext/xml/expat/xmltok -I/php-4.0.4pl1/ext/xml/expat/xmlparse -I/php-4.0.4pl1/TSRM  -DAIX=43 -DAIX_BIND_PROCESSOR -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -DXML_BYTE_ORDER=21 -O2  -c libmysql.c
In file included from libmysql.c:9:
global.h:525: conflicting types for `int8'
/usr/include/sys/inttypes.h:622: previous declaration of `int8'
global.h:526: warning: redefinition of `int16'
/usr/include/sys/inttypes.h:623: warning: `int16' previously declared here
global.h:536: warning: redefinition of `int32'
/usr/include/sys/inttypes.h:624: warning: `int32' previously declared here
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.

Can you help me please?
Jana

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-18 16:45 UTC] sniper@php.net
This should be fixed in latest CVS (and maybe also in the 
PHP 4.0.6RC3) so please try them out. Reopen if still no workie.

Latest CVS:

http://snaps.php.net/

4.0.6RC3

http://www.php.net/~andi/php-4.0.6RC3.tar.gz

(if above link doesn't work, try with RC4)

--Jani

 [2001-06-19 07:28 UTC] jana dot korpasova at unex dot cz
I'm traying new version 4.0.6RC3
./configure --with-oci8=/oracle_ais/ais --with-apxs=/oracle_ais/ais/Apache/Apache/bin/apxs
was OK
but make gets error (file libnlsrtl3 dosn't exist in all server)

Error message:
Making all in .
        /bin/sh /php-4.0.6RC3/libtool --silent --mode=link gcc  -I. -I/php-4.0.6RC3/ -I/php-4.0.6RC3/main -I/php-4.0.6RC3 -I/include -I/php-4.0.6RC3/Zend -I/php-4.0.6RC3/ext/mysql/libmysql -I/oracle_ais/817/rdbms/public -I/oracle_ais/817/rdbms/demo -I/php-4.0.6RC3/ext/xml/expat/xmltok -I/php-4.0.6RC3/ext/xml/expat/xmlparse -I/php-4.0.6RC3/TSRM  -DAIX=43 -DAIX_BIND_PROCESSOR -DUSE_HSREGEX -DEAPI -DUSE_EXPAT -DSUPPORT_UTF8 -DXML_BYTE_ORDER=21 -O2   -o libphp4.la -rpath /php-4.0.6RC3/libs -avoid-version -L/oracle_ais/817/lib  -R /oracle_ais/817/lib stub.lo  Zend/libZend.la  sapi/apache/libsapi.la  main/libmain.la  regex/libregex.la  ext/mysql/libmysql.la ext/oci8/liboci8.la ext/pcre/libpcre.la ext/posix/libposix.la ext/session/libsession.la ext/standard/libstandard.la ext/xml/libxml.la  TSRM/libtsrm.la -ldl -lclntsh -lpsa -lcore4 -lnlsrtl3 -lld -lbsd_r -lm -lodm -ldl -lcrypt -lbind -lm -ldl
collect2: Library libnlsrtl3 not found
make: 1254-004 The error code from the last command is 1.


Stop.
make: 1254-004 The error code from the last command is 1.


Stop.
oracle1:/php-4.0.6RC3 # 

Thanks for help.

 [2001-06-19 22:41 UTC] sniper@php.net
I don't think the OCI8 extension is (yet) compatible
with OCI9 libs. The configure at least seems to think
you have 8.0.x version installed.

 [2002-04-13 08:38 UTC] thies@php.net
reopen if problem is still there

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 06:05:45 2022 UTC