php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11517 GetImageSize returns nothing
Submitted: 2001-06-16 23:25 UTC Modified: 2001-06-19 08:34 UTC
From: andri at bofh dot is Assigned:
Status: Closed Package: GetImageSize related
PHP Version: 4.0.5 OS: Redhat Linux 7.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: andri at bofh dot is
New email:
PHP Version: OS:

 

 [2001-06-16 23:25 UTC] andri at bofh dot is
Wouldn't exactly call this a crash but it keeps me from doing what i'm trying to do and it doesnt return any information.

I have a digital camera called Canon Powershot S10 and I use a Windows program called Cam4you to extract the pictures.

I noticed when I'm using the GetImageSize function on these images i wasnt getting any results. Using a syntax like this... $fleah = GetImageSize("myimage.jpg");

I tried adding... or die("oh, oh.. something is wrong"); at the end and it always terminates.

This might be caused by some strange header in my jpeg files but I'm not sure. 

Since i wasnt able to upload any files with this bug report I'll just include an url for the picture.

http://ancient.scrolls.org/badimage

This is a huge cocacola can here in Iceland :)

Please keep me informed...

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-17 05:18 UTC] jmoore@php.net
There were some fixes for this please try latest snapshot or CVS.

- James
 [2001-06-19 08:34 UTC] sniper@php.net
I tested with your image and this is fixed in latest CVS
and in PHP 4.0.6RC3:

http://www.php.net/~andi/php-4.0.6RC3.tar.gz

(if above link doesn't work, try with RC4)


 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Fri Apr 16 00:01:23 2021 UTC