php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11502 wrong argument count to fopen does not report error
Submitted: 2001-06-15 09:56 UTC Modified: 2001-06-15 10:17 UTC
From: tony_leake at hotmail dot com Assigned:
Status: Not a bug Package: Filesystem function related
PHP Version: 4.0.4pl1 OS: linux 2.2.18 kernel
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: tony_leake at hotmail dot com
New email:
PHP Version: OS:

 

 [2001-06-15 09:56 UTC] tony_leake at hotmail dot com
This is the part of a script where I noticed the description

$fp = fopen("excel4.csv","w");
fputs($out_file);
fclose($fp);

I did not have a file pointer argument to fputs and no error was reported. The file was created but was empty. 

Below is configure info from phpinfo()
'./configure' '--prefix=/usr' '--with-apxs=/usr/sbin/apxs' '--enable-trans-sid' '--enable-track-vars' '--disable-debug' '--with-ming' '--enable-calendar' '--disable-ftp' '--with-mysql=/usr/local/mysql' '--with-mhash' '--enable-sysvshm' '--enable-sysvsem' '--with-imap=/usr/src/imap-2000/' '--with-gd' '--with-jpeg-dir=/usr/lib' '--with-xpm-dir=/usr/X11R6/' '--with-mcrypt' '--with-swf=/usr/src/libswf-0.99' '--with-snmp' '--with-ucd-snmp-hack' '--with-zlib' '--with-bz2' '--with-ldap'

We don't have a php.ini file. the OS is linux with a 2.2.18 kernel. It is not any specific distribution, the company I work of rhas their own.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-15 10:17 UTC] sniper@php.net
Works for me just fine.
(gives a warning) 
Check your error_reporting setting.

 
PHP Copyright © 2001-2017 The PHP Group
All rights reserved.
Last updated: Sun Nov 19 01:31:42 2017 UTC