php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11484 Upload Problem
Submitted: 2001-06-14 07:39 UTC Modified: 2001-06-14 13:11 UTC
From: ufuk dot kocolu at isletmekulubu dot com Assigned:
Status: Not a bug Package: *Directory/Filesystem functions
PHP Version: 4.0.5 OS: Linux REDHAT 6.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: ufuk dot kocolu at isletmekulubu dot com
New email:
PHP Version: OS:

 

 [2001-06-14 07:39 UTC] ufuk dot kocolu at isletmekulubu dot com
When I upload a file with copy() function or something else script adds uploaded file's mime type into uploaded file.
For example if I upload a gif file called pic.gif:
Pic.gif damages and iti includes "image/gif" at the head of the file when I open it with notepad. Then doesn't happen on my NT4.0 server but the problem is on REDHAT 6.2 machine. magic_quotes_gpc is off on server config but I tried and failed with set_magic_quotes_runtime.
Whats the problem? 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-14 13:11 UTC] sniper@php.net
Your script is broken. Uploading works for me just fine
with PHP 4.0.5 / PHP 4.0.6RC3


 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jan 25 23:01:24 2020 UTC