php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11478 setcookie with time problem
Submitted: 2001-06-13 21:12 UTC Modified: 2001-07-22 13:14 UTC
From: taitg at digitalimagination dot com Assigned:
Status: Closed Package: HTTP related
PHP Version: 4.0.5 OS: freeBSD 4.2
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: taitg at digitalimagination dot com
New email:
PHP Version: OS:

 

 [2001-06-13 21:12 UTC] taitg at digitalimagination dot com
When sending a cookie and using the time to expire in it the cookie wil not show but PHP thinks it was delivered (from a logical statement). 
====================================
config line:   
./configure --enable-track-vars --with-mysql --with-apxs=/usr/local/apache/bin/apxs
====================================
Server setup Freebsd 4.2, mysql 3.23, Apache 1.14-i386 build_freeBSD, php 4.0.5

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-13 23:00 UTC] sniper@php.net
This is not bug and this place is not the correct place
to ask support questions.

 [2001-06-14 02:03 UTC] taitg at digitalimagination dot com
Let me clarify and you can tell if this is not a bug. PHP is suppossed to declare cookies based of the NS cookie standard. 
http://developer.netscape.com:80/docs/manuals/js/client/jsguide/cookies.htm 

I have a situation where if I set a cookie as:

setcookie("test", "value");

It works

If I set it just like php says it is set (based on these standards):
int setcookie (string name [, string value [, int expire [, string path [, string domain [, int secure]]]]])

setcookie("test", "value", time()+15000, "/", ".mysite.com");

Then the cookie does not exsist. I have tested it off of Linux and it has been fine as the same format, same Apache server, same version of PHP. Am I way over stepping my boundries here or would you call that a bug?

--Tait
 [2001-06-19 08:29 UTC] sniper@php.net
Please add a complete but short example script into
this report which can be used to reproduce this problem.

And I assume you know that if you use the path / host
the cookies are visible on only that path and host.

Also, many browsers handle them differently. 
So please include the browser and version into this
bug report with which you get this.

--Jani

 [2001-07-22 13:14 UTC] andy@php.net
no feedback after 35+ days.
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Sep 16 04:01:26 2019 UTC