php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11463 Wrong handling of text string "&currency"
Submitted: 2001-06-13 07:42 UTC Modified: 2001-06-15 06:05 UTC
From: ta at alea-active dot com Assigned:
Status: Not a bug Package: *General Issues
PHP Version: 4.0.4pl1 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ta at alea-active dot com
New email:
PHP Version: OS:

 

 [2001-06-13 07:42 UTC] ta at alea-active dot com
It's not possible to output any content that includes the phrase "&curren" in it. The &curren gets replaced by some mystic char "?".

The following script reproduces the error:

<?

    // This gets displayed wrong
    echo "&curren";
    echo "<BR>";
    // Ths gets displayed wrong also
    echo "&currency";
    echo "<BR>";
    // This is rendered correctly
    echo "&curre";

?>

This error is reproducable on the php sites also (zend.com/php3.com). Just search for something and type "&curren" as the search string.


Sincerely

Tom Arnold
Chief Management Application Services
alea active GmbH

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-13 13:29 UTC] sniper@php.net
You gotta be kidding? Don't you know anything about HTML??
This is definately NOT a bug in PHP..


 [2001-06-15 06:05 UTC] ta at alea-active dot com
You're right. I already saw that. It's an IE bug, IE auto completes the &curren statement to &curren; while netscape doesn't do that.
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Jul 04 04:05:46 2022 UTC