php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11456 Apache cannot locate php "module".
Submitted: 2001-06-13 01:50 UTC Modified: 2001-06-14 21:57 UTC
From: nhicks at mediaone dot net Assigned:
Status: Not a bug Package: Installation problem
PHP Version: 4.0.5 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: nhicks at mediaone dot net
New email:
PHP Version: OS:

 

 [2001-06-13 01:50 UTC] nhicks at mediaone dot net
Running Apache just fine, just used the test configuration option, and got an error on this line in the httpd.conf

LoadModule php4_module "c:/php/sapi/php4apache.dll"

(tried with and without quotes)

Error Loading module c:/php/sapi/php4apache.dll: (126) Specified Module could not be found.

I checked, it's exactly where the conf file says that it is.  possibly a problem with apache?  don't know :)

I definitely have latest versions of Apache and PHP, as of 6/12/2001.

thanks in advance

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-13 10:40 UTC] sniper@php.net
Works for me just fine. Put the module into the
apache modules directory and use this line instead:

LoadModule php4_module modules/php4apache.dll

Also, READ the install.txt thatcomes with the package..
You need to copy some dlls to someplace in your system..

--Jani

 [2001-06-13 13:12 UTC] nhicks at mediaone dot net
nope, doesn't work -- followed the instructions in install.txt exactly, *and* your email instructions.  Same error message, but the path now reflects the /modules/php4apache.dll change (c:\program files\apache group\....)


If need be, i can supply my httpd.conf or php.ini, or whatever is needed.

thanks again


 [2001-06-14 13:02 UTC] sniper@php.net
So what DID you do? Exactly? No need for WHOLE httpd.conf,
only the line you put in it..

--Jani

 [2001-06-14 19:55 UTC] nhicks at mediaone dot net
probably want to tell everyone this/add it to the install.txt -- using the Loadmodule directive in your httpd.conf is bogus.  that's the line that causes the error, and php now runs fine on my apache server without it present.  maybe something work fixing, i don't know :)
 [2002-08-03 13:22 UTC] jackie_box at yahoo dot com
I encountered the same problem with the error of loading the module.  My version is the lastest Apache2 and the latest PHP...  What could I do next?
 [2003-05-08 17:24 UTC] h dot pijpers at merit dot unimaas dot nl
sniper's right, just put the php4apache.dll in modules, add LoadModule php4_module modules/php4apache.dll in the httpd.conf and it works fine
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Fri Jan 21 19:03:36 2022 UTC