|  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11445 PHP4+IMAP+APACHE 1.3.20 causes "undefined symbol: mxdriver"
Submitted: 2001-06-12 17:14 UTC Modified: 2001-06-14 22:17 UTC
From: andu at alliednetworks dot net Assigned:
Status: Not a bug Package: IMAP related
PHP Version: 4.0.5 OS: Linux RedHat 7.1
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
Block user comment
Status: Assign to:
Bug Type:
From: andu at alliednetworks dot net
New email:
PHP Version: OS:


 [2001-06-12 17:14 UTC] andu at alliednetworks dot net
If I try to compile PHP4 with IMAP support and Apache 1.3.20
I get the following error while starting the webserver: undefined symbol: mxdriver.
Here's how I configured Apache:
./configure \
"--with-layout=Apache" \
"--enable-module=ssl" \
"--enable-module=so" \
"--enable-module=access" \
"--enable-module=alias" \
"--enable-module=mime" \
"--enable-module=status" \

Here's the one for PHP
"./configure" \
"--with-apxs=/usr/local/apache/bin/apxs" \
"--with-config-file-path=/etc" \
"--enable-bcmath" \
"--with-bz2" \
"--enable-calendar" \
"--enable-ftp" \
"--with-gd=/usr/" \
"--with-jpeg-dir=/usr/" \
"--with-xpm-dir=/usr/" \
"--with-imap" \
"--with-kerberos" \
"--with-mysql=/usr/local/mysql/" \
"--with-pspell" \
"--enable-trans-sid" \
Please help, this is urgent
Thank you !

P.S: I alo tried using export LDFLAGS="-L/usr/kerberos/lib -lkrb5 -lgssapi_krb5 -lpam"
before runnig configure. The IMAP is the one that comes with REDHAT


Add a Patch

Pull Requests

Add a Pull Request


AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-12 18:53 UTC]
Closed, not bogus..

 [2001-06-13 10:01 UTC]
Did you compile it from sources? Or is it again from RPM?
If latter, you HAVE to install the devel RPM of it too.

If former, you first compile it, and then copy the necessary
files to right places (easy way is to just copy all .h files 
to somewhere like, /www/imap/include and the c-client.a to /www/imap/lib/libc-client.a and use --with-imap=/www/imap )


 [2001-06-13 20:45 UTC] andu at alliednetworks dot net
I compiled it from source and installed everything I needed.

The problem is not at compilation time, but when I try to start Apace with php support.
That's when I get the error...
I also get the same error if I try to compile PHP as a static module and not as DSO but this time I get the error while compiling apache

I also tried not to install IMAP support but instead write a IMAP class from scratch.
The problem is that when I open a socket connection to 143 I can't read any data from that port. I mean I can send data, I can log in (it shows up in my logs) but I read the feedback from server I can only write to it.

Thank you for any of your help,
 [2001-06-14 22:17 UTC] andu at alliednetworks dot net
Thanks for all your help !
I tried everything but I still get the error.
I'll just give up IMAP
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Wed Feb 28 17:01:30 2024 UTC