php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11411 Java support doesn't work when oci8 support is also compiled it
Submitted: 2001-06-11 20:15 UTC Modified: 2001-06-19 14:27 UTC
From: s dot mccleary at operon dot com Assigned:
Status: Closed Package: Java related
PHP Version: 4.0.5 OS: Linux(slackware) 2.2.14
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: s dot mccleary at operon dot com
New email:
PHP Version: OS:

 

 [2001-06-11 20:15 UTC] s dot mccleary at operon dot com
Configure options: 
--without-mysql --with-apxs=/usr/local/apache/bin/apxs --with-java=/usr/local/java --enable-trans-sid --with-gd=/usr/local --without-xml --with-oci8

Using IBM JVM 1.3

Works fine when I do NOT have oci8 support compiled in.  As soon as I try it with oci8 support, java support stops working.  Attempting to load a PHP page that uses java will never load.  Nothing is logged to the error log.


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-11 20:45 UTC] s dot mccleary at operon dot com
Nevermind.  Compiled apache with pthread support and now it seems to be working.

Very strange that it worked without oci8 support, though, and then didn't with oci8 support, while apache had no pthread support the whole time.
 [2001-06-19 14:27 UTC] sniper@php.net
just FYI: This is actually a glibc bug that prevents
something linked with phtread to work if not all the parties 
are not linked with pthread. In this case, Apache.

 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 00:03:49 2021 UTC