php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Request #11410 Debug function: get caller function stack
Submitted: 2001-06-11 17:39 UTC Modified: 2001-06-14 16:28 UTC
From: bachi2 at insign dot ch Assigned:
Status: Not a bug Package: Feature/Change Request
PHP Version: 4.0.5 OS: (all)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bachi2 at insign dot ch
New email:
PHP Version: OS:

 

 [2001-06-11 17:39 UTC] bachi2 at insign dot ch
It would be a *HUGE* debugging help, if there would be a function that returns the current caller function stack. So on a given position or in an error condition, one could just output the nested function calls to this position. 

Debugging without is quite hard if you have utility functions/methods that are used widely in a project. If they produce an error because of the params, how can u find out which function/method called it (thus must be debugged)?

Such a debugging function would just be great - imho of better use than the variables snapshot with the current debug functions.

Regards, Martin Bachmann


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-14 16:28 UTC] sniper@php.net
submitted twice

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Sat Jan 29 11:03:35 2022 UTC