php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11407 php_mysql.c mysql_field_type returns unknown for tiny int and year types
Submitted: 2001-06-11 16:42 UTC Modified: 2001-06-12 01:59 UTC
From: kraai2 at home dot com Assigned:
Status: Not a bug Package: MySQL related
PHP Version: 4.0.5 OS: all
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: kraai2 at home dot com
New email:
PHP Version: OS:

 

 [2001-06-11 16:42 UTC] kraai2 at home dot com
patch for YEAR problem:
1556a1557,1559
                                case FIELD_TYPE_YEAR:
                                        return "year";
                                        break;

I don't understand why the tiny int doesn't work, either, 
the macro's defined, but looks like it's getting lost in 
the #ifdef clause in php_mysql.c

Thanks,

--jim

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-12 01:51 UTC] sniper@php.net
This depends on the installed version of your 
mysql clientlibs. They have to be newer than 3.22

--Jani

 [2001-06-12 01:59 UTC] kraai2 at home dot com
my installed libs are 3.23.36

When I applied the patch that I created, it correctly 
reports mysql year types.

When I remove the #ifdef from around _TINY in 
php_mysql.c, it correctly reports mysql tiny int 
types.

It's all working for me, I just wanted to pass the 
goodies on to others who know more than I.

--jim

 
PHP Copyright © 2001-2023 The PHP Group
All rights reserved.
Last updated: Sun Jan 29 07:05:53 2023 UTC