php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #114 Last-Modified and Date wrong in header.
Submitted: 1998-02-27 19:41 UTC Modified: 1998-03-29 04:35 UTC
From: veebert at dimensional dot com Assigned: jim (profile)
Status: Closed Package: Other
PHP Version: 3.0 Latest CVS OS: Linux Redhat 5.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: veebert at dimensional dot com
New email:
PHP Version: OS:

 

 [1998-02-27 19:41 UTC] veebert at dimensional dot com
I have a page that is different each time loaded.
Today it stoped changing after I recompiled with
the latest CVS.

The Date: and Last-Modified: header lines are set
one day into the future. If I use header comands
like the following it fixes the problem.

header("Date: ".date("D, d M Y H:i:s")." GMT");
header("Last-Modified: ".date("D, d M Y H:i:s")." GMT");

Apache/1.2.5 - version of apache used.

 


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-03-29 04:35 UTC] ars
From Jim:
Please verify that this is still happening. I was unable to reproduce this
with PHP/3.0RC and Apache/1.3b3.

---

Date: Sat, 28 Mar 1998 23:47:27 -0700
From: Rex Logan <veebert@dimensional.com>
The porblem was caused because I compiled php with the
system regex and apache with the bundled regex.  You can
delete this bug.
Sorry I forgot to report my soulution.                             

 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Thu May 19 08:05:45 2022 UTC