php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11374 Browsers other then IE write empty session files to /tmp.
Submitted: 2001-06-09 01:14 UTC Modified: 2001-06-14 16:13 UTC
From: bartjan dot buijs at hi-technet dot com Assigned:
Status: Not a bug Package: Session related
PHP Version: 4.0.5 OS: FreeBSD 3.0-RELEASE #5
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: bartjan dot buijs at hi-technet dot com
New email:
PHP Version: OS:

 

 [2001-06-09 01:14 UTC] bartjan dot buijs at hi-technet dot com
Browsers other then IE write empty session files to /tmp.
Used software: APACHE 1.3.20 / PHP 4.0.5 on FreeBSD 3.0-RELEASE #5

Configure command:
'./configure' '--with-mysql=/usr/local' '--with-apache=../apache_1.3.20' '--enable-track-vars' '--enable-ftp'

Default php.ini file used.

Problem also existed in older version APACHE 1.3.6 / PHP 4.0.1pl2 on FreeBSD 3.0-RELEASE #5

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-09 01:45 UTC] sniper@php.net
And where does IE write them? What do you mean by 'empty session files'? As PHP is server-side, it's a bit impossible
to be browser that causes this behaviour.

Do you have any short example code of this?

--Jani

 [2001-06-10 01:25 UTC] bartjan dot buijs at hi-technet dot com
It isn't the browser that causes this behaviour, it's the protocol. When a php script that uses sessions is requested using HTTP/1.0, created session files are empty. When the same script is requested using HTTP/1.1 everything works fine.

Sample url: http://www.hi-technet.com/php/count_me.php
Sample code:

<?
session_start();

echo session_id();

if(!isset($count)) {
  session_register("count");
  $count = 1;
}
else {
  $count++;
}

echo "<p>You've been here $count times.  Thanks!</p>";

?>
 [2001-06-10 02:52 UTC] sniper@php.net
This works for me just fine with PHP 4.0.6RC3.
Could you please try it? You can find it here:

http://www.php.net/~andi/php-4.0.6RC3.tar.gz

--Jani

 [2001-06-12 14:07 UTC] bartjan dot buijs at hi-technet dot com
Hi,

I've tried to get sessions working with version 4.0.1pl2 and version 4.0.5. What is the chance it will work with this release candidate? Isn't there another way to verify this problem? Can you change the description of this bug?
 [2001-06-14 13:38 UTC] sniper@php.net
If you don't want to test it, it's your problem. 
This works for me just fine as it does for hundreds of
other people too. Check your settings.

 [2001-06-14 16:13 UTC] bartjan dot buijs at hi-technet dot com
We aren't making any progress this way.
First, there are many people with empty session files.
It isn't just me.....
Like you said, it works just fine for me.
Not for everybody.
I simple can't install new software just like this.
There are many sites running on that server.
I rather not risk downtime. So, please give me a better reason then, "please try it"!
 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Sat Oct 19 17:01:27 2019 UTC