php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11371 strtotime() return -1 for year 1939-1969
Submitted: 2001-06-08 20:18 UTC Modified: 2001-06-13 14:17 UTC
From: satit at thaijoin dot com Assigned:
Status: Not a bug Package: Date/time related
PHP Version: 4.0.5 OS: win98
Private report: No CVE-ID: None
View Add Comment Developer Edit
Anyone can comment on a bug. Have a simpler test case? Does it work for you on a different platform? Let us know!
Just going to say 'Me too!'? Don't clutter the database with that please !
Your email address:
MUST BE VALID
Solve the problem:
42 - 17 = ?
Subscribe to this entry?

 
 [2001-06-08 20:18 UTC] satit at thaijoin dot com
I use function strtotime() for count days and have return value -1 in year 1939 to 1969 on php 4 for windows and php 3.0.16 to and php 3.0.16 have error illegal operation in year 1938 and 2038. Php for linux have return value complete. Have any idea for function count days?

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-06-09 01:59 UTC] sniper@php.net
Please include a short example script into this report.

 [2001-06-09 18:29 UTC] satit at thaijoin dot com
This is my script for test function strtotime

<?
for ($year=1900;$year <2010;$year++){
$fdate2= "20 jun ".$year;
$date2=strtotime($fdate2); 
echo "$year ,$date2<br>";
}

$day = date('d M Y');
echo "$day<br>";
$fdate1= strtotime("9 jun 1959");
$fdate2= strtotime($day);
$day = $fdate2-$fdate1;
$days= round($day/86400); 
echo "$fdate1<br>";
echo "$fdate2<br>";
echo "days = ".$days."<br>";
echo "years = ".round($days/365);
?>
 [2001-06-13 14:17 UTC] sniper@php.net
See this manual page for more info about UNIX timestamps:

http://www.php.net/manual/en/function.mktime.php

this is not a bug in PHP but in Windows..

--Jani

 
PHP Copyright © 2001-2024 The PHP Group
All rights reserved.
Last updated: Mon May 27 00:01:31 2024 UTC