php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #1128 phpinfo() crashes
Submitted: 1999-02-08 19:21 UTC Modified: 1999-02-13 12:32 UTC
From: steffann at nederland dot net Assigned:
Status: Closed Package: Reproducible Crash
PHP Version: 3.0 Latest CVS (08/02/1999) OS: Linux (Redhat 5.2)
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: steffann at nederland dot net
New email:
PHP Version: OS:

 

 [1999-02-08 19:21 UTC] steffann at nederland dot net
Script:
<?php phpinfo(); ?>

Some data is sent (amount varies). Same config with 3.0.5 is OK. I haven't tested 3.0.6 yet.

Configuration:
./configure --enable-sysvsem --enable-sysvshm --with-ldap --with-snmp=/usr --with-xml --with-pdflib --with-imap --with-mysql=/usr --with-apache=/usr/local/src/apache_1.3.4 --with-pgsql --with-dbase=yes --with-filepro=yes --disable-short-tags --enable-url-fopen-wrappers=yes --enable-track-vars --with-zlib --enable-memory-limit --enable-debugger --enable-debug

Not using a ini file.

Backtrace:
Program received signal SIGSEGV, Segmentation fault.
0x4012f861 in strlen ()
(gdb) bt
#0  0x4012f861 in strlen ()
#1  0x80ceadb in ap_bputs ()
#2  0x80df09b in ap_rputs ()
#3  0x807cea6 in php3_puts ()
#4  0x80adfe9 in _php3_info ()
#5  0x80ae200 in php3_info ()
#6  0x80c47ac in phpparse ()
#7  0x807e9d6 in _php3_build_argv ()
#8  0x807ec74 in apache_php3_module_main ()
#9  0x807c054 in send_php3 ()
#10 0x807c0ba in send_parsed_php3 ()
#11 0x80cf78b in ap_invoke_handler ()
#12 0x80e1f71 in ap_some_auth_required ()
#13 0x80e237c in ap_internal_redirect ()
#14 0x806e4f1 in ap_get_server_built ()
#15 0x80cf78b in ap_invoke_handler ()
#16 0x80e1f71 in ap_some_auth_required ()
#17 0x80e1fd0 in ap_process_request ()
#18 0x80d9ec5 in ap_child_terminate ()
#19 0x80da050 in ap_child_terminate ()
#20 0x80da1ab in ap_child_terminate ()
#21 0x80da788 in ap_child_terminate ()
#22 0x80dafbb in main ()

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1999-02-13 12:32 UTC] steffann
Crash caused by NULL value in apache-env from other module.
Fixed in CVS

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri May 29 17:01:40 2020 UTC