php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11232 compiling extention Fribidi
Submitted: 2001-06-01 02:37 UTC Modified: 2002-09-18 06:42 UTC
From: boaz at corky dot net Assigned:
Status: Closed Package: *Languages/Translation
PHP Version: 4.0.5 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: boaz at corky dot net
New email:
PHP Version: OS:

 

 [2001-06-01 02:37 UTC] boaz at corky dot net
RE: bug #7040


couldnt compile the fribidi extention for some reason:
------------------------------------------------>8
fribidi.c: In function `php_minit_fribidi':
fribidi.c:71: `FRIBIDI_CHARSET_8859_6' undeclared (first use in this function)
fribidi.c:71: (Each undeclared identifier is reported only once
fribidi.c:71: for each function it appears in.)
fribidi.c:72: `FRIBIDI_CHARSET_8859_8' undeclared (first use in this function)
fribidi.c: In function `zend_if_fribidi_log2vis':
fribidi.c:192: `FRIBIDI_CHARSET_8859_6' undeclared (first use in this function)
fribidi.c:195: `FRIBIDI_CHARSET_8859_8' undeclared (first use in this function)
make[3]: *** [fribidi.lo] Error 1


--------------------------------------------------->8
i believe the library installation is functional, though.

any ideas? (since it's not really documented)

(STAS: sorry it took a while getting back to you on this, it's a production site, so i don't compile that often. had to use PHP code for hebrew flipping in the meantime - damm slow, but not buggy).

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-08-19 02:35 UTC] sniper@php.net
Fixed in CVS. (and also in soon to be released 4.0.7)

--Jani

 [2001-08-19 02:36 UTC] sniper@php.net
One note: Fribidi 0.9.0 is now required.

 [2002-09-18 06:42 UTC] tal@php.net
Just a note: to compile fribidi in current cvs, fribidi 0.10.4 is required (might work with >=0.10.0, not tested though).\

-Tal
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Fri Aug 14 00:01:27 2020 UTC