php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #112 mSQL support fails to compile
Submitted: 1998-02-27 14:31 UTC Modified: 1998-03-01 19:10 UTC
Votes:1
Avg. Score:4.0 ± 0.0
Reproduced:0 of 0 (0.0%)
From: stegu at itn dot liu dot se Assigned: zeev (profile)
Status: Closed Package: mSQL related
PHP Version: 3.0b5 OS: Linux 2.0.33
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: stegu at itn dot liu dot se
New email:
PHP Version: OS:

 

 [1998-02-27 14:31 UTC] stegu at itn dot liu dot se
Trying to compile PHP 3.0b5 under Linux with
mSQL support, I get the following fatal error.
PHP 3.0b4 compiles just fine with mSQL support
with identical configuration on the very same
system.
(Latest mSQL version 2.0.3)

functions/msql.c: In function `php3_msql_fetch_field':
functions/msql.c:1191: `PRI_KEY_FLAG' undeclared (first use this function)
functions/msql.c:1191: (Each undeclared identifier is reported only once
functions/msql.c:1191: for each function it appears in.)
functions/msql.c: In function `php3_msql_field_info':
functions/msql.c:1285: `PRI_KEY_FLAG' undeclared (first use this function)
/usr/local/Hughes/include/msql.h: At top level:
/usr/local/Hughes/include/msql.h:99: warning: `msqlTypeNames' defined but not us
ed
make: *** [functions/msql.o] Error 1


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [1998-03-01 19:10 UTC] zeev
Looks like mSQL 1 is detected for some reason.
There weren't any changes in msql.c since beta 3.

closed - user was unable to reproduce the problem anymore,
probably bad config.cache or something of the sort...
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Tue Dec 07 00:03:49 2021 UTC