php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11192 Calculate issue
Submitted: 2001-05-30 07:48 UTC Modified: 2001-05-30 10:52 UTC
From: ading at copeland-corp dot com Assigned:
Status: Not a bug Package: Performance problem
PHP Version: 4.0.4pl1 OS: nt server 4.0
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: ading at copeland-corp dot com
New email:
PHP Version: OS:

 

 [2001-05-30 07:48 UTC] ading at copeland-corp dot com
<?
  $b = 0;
  $o = 0.1;
  $k = 1000;
  for($i=0;$i<$k;$i++)
    $b += $o;
    
  echo $b."|". $o * $k;
?>

the result will be '99.999999999999|100', it isn't correct!

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-30 10:52 UTC] sniper@php.net
not a bug. check bug report #8164

--Jani

 
PHP Copyright © 2001-2019 The PHP Group
All rights reserved.
Last updated: Mon Dec 09 23:01:24 2019 UTC