php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11164 output conversion failed due to conv error
Submitted: 2001-05-29 04:07 UTC Modified: 2001-11-29 06:02 UTC
From: negativ at linuxnews dot pl Assigned:
Status: Not a bug Package: DOM XML related
PHP Version: 4.0.5 OS: Linux
Private report: No CVE-ID: None
Welcome back! If you're the original bug submitter, here's where you can edit the bug or add additional notes.
If this is not your bug, you can add a comment by following this link.
If this is your bug, but you forgot your password, you can retrieve your password here.
Password:
Status:
Package:
Bug Type:
Summary:
From: negativ at linuxnews dot pl
New email:
PHP Version: OS:

 

 [2001-05-29 04:07 UTC] negativ at linuxnews dot pl
        $doc = xmldoc('<?xml version="1.0" encoding="iso-8859-2"?><p/>');
        $r = $doc->root();
        $r->new_child("test","z??w");
        echo $doc->dumpmem();

modules: domxml, iconv
 php: 4.0.5 (cgi)

 output:

output conversion failed due to conv error
Bytes: 0xF3 0xB3 0x77 0x3C
xmlOutputBufferWrite: encoder error
X-Powered-By: PHP/4.0.5
Content-type: text/plain

<?xml version="1.0" encoding="iso-8859-2"?>
<p><test>zOK

 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-29 06:02 UTC] mfischer@php.net
To me this looks rather a proble with the characters or your systems locale or your libxml2 but not with PHP.

libxml2 uses its own calls to iconv() and there is little PHP can do about this.

Bogus (not a PHP bug).
 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Oct 31 20:01:24 2020 UTC