php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11162 pfsockopen closes connection after script finishes
Submitted: 2001-05-29 01:18 UTC Modified: 2002-06-18 18:31 UTC
From: gavin at flinet dot com Assigned:
Status: Not a bug Package: Sockets related
PHP Version: 4.0.4 OS: FreeBSD
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: gavin at flinet dot com
New email:
PHP Version: OS:

 

 [2001-05-29 01:18 UTC] gavin at flinet dot com
When using pfsockopen() it closes the connection as soon as the script finishes. According to the manual, the connection should remain open. I have had a few people write their own script to test this on their machine to make sure it wasn't my machine, or my code, and both of them also produced the same result. So I beleive this is either a bug with pfsockopen() or with the online documents.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-21 12:03 UTC] mfischer@php.net
Can try with latest RC and see if the problem still exists

http://www.php.net/~zeev/php-4.1.0RC3.tar.gz

Feedback.
 [2001-12-13 06:25 UTC] sander@php.net
No feedback. Closing.
 [2002-02-14 12:15 UTC] strange at unicon dot ru
The problem still exists!
Connection, opened by pfsockopen(), is closing when the script is finishes. (tested by just simple netcat -l and by multithreaded java chat server)

PHP Version 4.1.1
Apache/1.3.20
FreeBSD 4.5-STABLE
 [2002-03-02 13:48 UTC] sander@php.net
OK. Reopening.
 [2002-03-02 13:49 UTC] derick@php.net
Making this duplicate of  #15836 which I just marked a doc problem.

Derick
 [2002-03-02 13:50 UTC] sander@php.net
Do NOT open a new report for the same bug. I'm closing this one, see #15836 for more...
 [2002-06-18 18:31 UTC] sniper@php.net
correct status..

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Wed Jan 29 12:01:24 2020 UTC