php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11149 request_config is always a default (and faulty) value
Submitted: 2001-05-28 02:29 UTC Modified: 2001-05-29 07:00 UTC
From: emile at iris-advies dot com Assigned:
Status: Not a bug Package: Apache related
PHP Version: 4.0.5 OS: Debian Sid
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: emile at iris-advies dot com
New email:
PHP Version: OS:

 

 [2001-05-28 02:29 UTC] emile at iris-advies dot com
Our module uses the apache internal structure request_rec->request_config to fetch informatino about another module (mod_midgard). Since the request_config field we get from SG(server_context) is always 0x10000, ap_get_module_config segfaults because that value is wrong. I can peek in other modules running in the same apache handler and the value is different (and correct) there
See PHP bug #10628 on how to reproduce this bug.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-29 07:00 UTC] sniper@php.net
Please, this is something that should be discussed on the
developer mailing list. Not in bug database.

--Jani

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Tue Nov 24 21:01:23 2020 UTC