php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #11031 XML parser do not let use ']' in CDATA string
Submitted: 2001-05-22 17:18 UTC Modified: 2001-05-22 19:26 UTC
From: Mykolas at Labas dot Com Assigned:
Status: Not a bug Package: *XML functions
PHP Version: 4.0.4pl1 OS: Linux
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: Mykolas at Labas dot Com
New email:
PHP Version: OS:

 

 [2001-05-22 17:18 UTC] Mykolas at Labas dot Com
Extract from data I giving to parse:

<LongDesc><![CDATA[HP OmniBook XE3 Cel600 13 HPA 64/7 W[AN]]]></LongDesc> 

Parser executes data function two times:
for data: "HP OmniBook XE3 Cel600 13 HPA 64/7 W[AN" 
and for data: "]"

It happens only in case of using [] in the data string.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-22 19:26 UTC] derick@php.net
This is not a bug in PHP, but rather a property of the XML parser (which is external).
You need to escape your [ and ] 's

Derick
 
PHP Copyright © 2001-2021 The PHP Group
All rights reserved.
Last updated: Sat Nov 27 13:03:14 2021 UTC