php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10976 No support for other encoding in XSLT functions
Submitted: 2001-05-20 16:11 UTC Modified: 2001-06-12 04:38 UTC
From: lazaris at ceid dot upatras dot gr Assigned:
Status: Closed Package: Sablotron XSL
PHP Version: 4.0.5 OS: Windows 2000
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: lazaris at ceid dot upatras dot gr
New email:
PHP Version: OS:

 

 [2001-05-20 16:11 UTC] lazaris at ceid dot upatras dot gr
I run PHP 4.0.5 on Windows 2000 with Apache Web Server. The problem is that I can't use the function xslt_process() with strings containing non-English characters (Greek particularly). The only solution for now is to encode the strings to UTF-8, but this requires setting the browser's encoding to UTF-8 which forces me to encode everything to UTF-8 before displaying it. I contacted Ginger Alliance and they told me that Sablotron works ok when the PHP extension is linked to and compiled with ilibconv.dll BUT I don't know exactly how this is done. They said that Sterling Hughes is working on a new version for Sablotron and I would like to request that this new extension works with other character encodings too. 

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-21 03:02 UTC] swm@php.net
A sample script please.
 [2001-06-12 04:38 UTC] sniper@php.net
No feedback. Suggest you wait for 4.0.6 and update then.
If still no workie, reopen.

 
PHP Copyright © 2001-2020 The PHP Group
All rights reserved.
Last updated: Sat Jul 04 19:01:16 2020 UTC