php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10973 Setcookie does't work
Submitted: 2001-05-20 00:46 UTC Modified: 2002-06-18 18:29 UTC
From: theerapong at yahoo dot com Assigned:
Status: Not a bug Package: IIS related
PHP Version: 4.0.4pl1 OS: Win2k with IIS 5.0
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: theerapong at yahoo dot com
New email:
PHP Version: OS:

 

 [2001-05-20 00:46 UTC] theerapong at yahoo dot com
I try to Setcookie to write in client browser with this script

<? 
	if(!$CartID){
	$CartID=md5(uniqid(rand()));
	SetCookie("CartID",$CartID,time()+3600);
	}
?>

It's work well with Redhat with Apache but When I try to user this script in Win2k with IIS5.0 It doesn't work.
No cookie was write.
detail in PHP.in  as following:

session.auto_start Off 
session.cache_expire180 
session.cache_limiter nocache 
session.cookie_domain no value 
session.cookie_lifetime 0 
session.cookie_path / 
session.cookie_secure Off 
session.entropy_file no value 
session.entropy_length 0 
session.gc_maxlifetime 1440 
session.gc_probability 1 
session.name PHPSESSID 
session.referer_check no value 
session.save_handler files 
session.save_path /tmp 
session.serialize_handler php 
session.use_cookie On 

Thank you


Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-11-11 12:24 UTC] sander@php.net
Dupe of 12540 which has more info so I'm closing this one.
 [2002-06-18 18:29 UTC] sniper@php.net
Thank you for taking the time to report a problem with PHP.
Unfortunately your version of PHP is too old -- the problem
might already be fixed. Please download a new PHP
version from http://www.php.net/downloads.php

If you are able to reproduce the bug with one of the latest
versions of PHP, please change the PHP version on this bug report
to the version you tested and change the status back to "Open".
Again, thank you for your continued support of PHP.


 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Mon Nov 28 23:03:43 2022 UTC