php.net |  support |  documentation |  report a bug |  advanced search |  search howto |  statistics |  random bug |  login
Bug #10958 ltconfig in infinite loop looking for echo
Submitted: 2001-05-18 12:31 UTC Modified: 2001-06-12 04:38 UTC
From: charles dot fisher at alcoa dot com Assigned:
Status: Closed Package: Installation problem
PHP Version: 4.0.5 OS: HPUX 10.20
Private report: No CVE-ID: None
View Add Comment Developer Edit
Welcome! If you don't have a Git account, you can't do anything here.
You can add a comment by following this link or if you reported this bug, you can edit this bug over here.
(description)
Block user comment
Status: Assign to:
Package:
Bug Type:
Summary:
From: charles dot fisher at alcoa dot com
New email:
PHP Version: OS:

 

 [2001-05-18 12:31 UTC] charles dot fisher at alcoa dot com
I had to comment out the following lines in ltconfig and
hardcode my choice for echo:

#  IFS="${IFS=  }"; save_ifs="$IFS";
IFS="${IFS}${PATH_SEPARATOR}"
#  for dir in $PATH /usr/ucb; do
#    if (test -f $dir/echo || test -f $dir/echo$ac_exeext) &&
#       test "X`($dir/echo '\t') 2>/dev/null`" = 'X\t' &&
#       test "X`($dir/echo "$echo_test_string")2>/dev/null`"
= X"$echo_test_string"; then
#      echo="$dir/echo"
#      break
#    fi
#  done
#  IFS="$save_ifs"
echo=/usr/bin/echo

Not doing so keeps ltconfig in an infinite loop.

Patches

Add a Patch

Pull Requests

Add a Pull Request

History

AllCommentsChangesGit/SVN commitsRelated reports
 [2001-05-18 16:47 UTC] charles dot fisher at alcoa dot com
I had to comment out the following lines in ltconfig and
hardcode my choice for echo:

#  IFS="${IFS=  }"; save_ifs="$IFS";
IFS="${IFS}${PATH_SEPARATOR}"
#  for dir in $PATH /usr/ucb; do
#    if (test -f $dir/echo || test -f $dir/echo$ac_exeext) &&
#       test "X`($dir/echo '\t') 2>/dev/null`" = 'X\t' &&
#       test "X`($dir/echo "$echo_test_string")2>/dev/null`"
= X"$echo_test_string"; then
#      echo="$dir/echo"
#      break
#    fi
#  done
#  IFS="$save_ifs"
echo=/usr/bin/echo

Not doing so keeps ltconfig in an infinite loop.


NOTE: I did not have to use the HPUX 10.20 installation
instructions by paul_mckay@clearwater-it.co.uk in the php
docs. I used the native hp ansi c compiler, and the change
to the configure script was not required.

 [2001-05-21 19:17 UTC] sniper@php.net
In the latest CVS the libtool has been upgraded and the ltconfig file doesn't exist anymore. Could you please
try the latest CVS snapshot from http://snaps.php.net/
to verify if it works now.

--Jani

 [2001-06-12 04:38 UTC] sniper@php.net
No feedback, considered fixed.

 [2003-02-03 15:29 UTC] charles_fisher at bigfoot dot com
This problem can be resolved by running the following before the compile:

export ECHO="print -r"
 
PHP Copyright © 2001-2022 The PHP Group
All rights reserved.
Last updated: Wed Jul 06 23:04:05 2022 UTC